Bug Tracker

Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#465 closed bug (worksforme)

Opera 9.02

Reported by: jamwae@… Owned by:
Priority: major Milestone:
Component: ajax Version:
Keywords: Opera 9.02 bug jquery 1.0.3 Cc:
Blocked by: Blocking:

Description (last modified by joern)

Opera won't except returned data with the ajax mod in jquery 1.0.3.

I get the following error:

name: SyntaxError
message: Statement on line 1934: Syntax error in call to eval: line 1 : 
data = {status:1,msg:'success',r_id:100}
  Line 1934 of linked script http://pathtojquery/jquery.js
    return data;
  Line 1833 of linked script http://pathtojquery/jquery.js
    success(jQuery.httpData(xml, dataType), status);
  At unknown location
    [statement source code not available]

The difference between posting this error here, and viewing it in the opera error console is that between "data = " and the "{status:1,msg:'success',r_id:100}" there are four squares. Could it be some weird encoding issue?

Attachments (1)

OperaErrorConsole.gif (12.1 KB) - added by jamwae@… 13 years ago.
Opera Error Console

Download all attachments as: .zip

Change History (3)

Changed 13 years ago by jamwae@…

Attachment: OperaErrorConsole.gif added

Opera Error Console

comment:1 Changed 13 years ago by joern

Description: modified (diff)
Priority: blockermajor

Could you provide a testcase for this? And/or test it with the latest revision of jQuery?

comment:2 Changed 13 years ago by joern

Resolution: worksforme
Status: newclosed

I am unable to reproduce this.

Note: See TracTickets for help on using tickets.