Bug Tracker

Opened 10 years ago

Closed 9 years ago

Last modified 7 years ago

#4628 closed bug (duplicate)

Jquery.animate div with swf ( the swf blinks )

Reported by: dustinm Owned by:
Priority: major Milestone: 1.4
Component: effects Version: 1.3.2
Keywords: swf, animate, div Cc: dmccory@…
Blocked by: Blocking:

Description

The Setup: I have setup a basic html page using swfObject 2.0 to embed a flash piece in a container wrapped with a wrapper div. Then using Jquery I intend on animating the height of the wrapper div allowing the flash file to stretch within the div. The animate code below works as expected in IE6 but not in FireFox 3. I have tried this using MooTools animation and it works cross browser. So I do not believe this to be a plugin|rendering issue for Firefox. It has to lie within the code set of Jquery.

The Problem: The flash file looks to be reloading and starts blinking a few times during the animation cycle.

The Code:

<div id="swfWrapper">

<div id="swfContainer">

This div get replaced with a swf using swfObject 2

</div>

</div>

$(document).ready(function() {

Neither of these options work in FireFox 3.

$("#swfWrapper").animate( {height:1000}, 1000); $("#swfWrapper").effect("size", {to:{height:1000}}, 1000);

});

Change History (5)

comment:1 Changed 10 years ago by dustinm

This problem also occurs when you use a direct embed method ( object & embed tags ) for the swf.

comment:2 Changed 10 years ago by Joust

This might be a duplicate of #4872.

Generally, jQuery breaks flash when animate()ing on firefox. And no fix yet even though it's so simple to mend.

comment:3 Changed 9 years ago by dmethvin

Component: unfiledfx

comment:4 Changed 9 years ago by addyosmani

Resolution: duplicate
Status: newclosed

comment:5 Changed 9 years ago by addyosmani

Duplicate of #4872.

Note: See TracTickets for help on using tickets.