Bug Tracker

Opened 10 years ago

Closed 10 years ago

#4569 closed bug (duplicate)

Sizzle/Selector Bug: Siblings selector in IE, FF, and Opera

Reported by: bbonifield Owned by: john
Priority: major Milestone: 1.4
Component: selector Version: 1.3.2
Keywords: Cc:
Blocked by: Blocking:

Description

An attempt to pull siblings using $("#id ~ *") [ where #id is a div element ] will return an empty set. I took the code sample from http://docs.jquery.com/Selectors/siblings#prevsiblings and replaced the span#prev element with div#prev, and it no longer works in IE, FF, or Opera. The same code works properly in Webkit based browsers.

Working: http://jsbin.com/upuze Not working: http://jsbin.com/ujexu

Change History (2)

comment:1 Changed 10 years ago by foyb

see #4931 for same bug... ;) (works fine with ffox 3.5.2 btw, the examples do not differ in ffox 3.5.2 ...)

comment:2 Changed 10 years ago by john

Resolution: duplicate
Status: newclosed

Duplicate of #4243.

Note: See TracTickets for help on using tickets.