Bug Tracker

Opened 11 years ago

Closed 11 years ago

#4563 closed bug (fixed)

Memory Leaks in IE

Reported by: dannynm Owned by: brandon
Priority: major Milestone: 1.4
Component: support Version: 1.3.2
Keywords: memory, leak, support, ie Cc:
Blocked by: Blocking:

Description

Discussion here:

http://groups.google.com/group/jquery-dev/browse_thread/thread/d127129441e26e52

jQuery seems to leak a lot of elements in IE. You can test for them using Drip. Most of them appear to come from the jQuery.support object, caused by removeChild calls.

Change History (4)

comment:1 Changed 11 years ago by brandon

Owner: set to brandon

comment:2 Changed 11 years ago by brandon

Resolution: fixed
Status: newclosed

this is fixed in r6310

comment:3 Changed 11 years ago by dannynm

Resolution: fixed
Status: closedreopened

This does not appear to fix any of the leaks. See discussion linked above in the jQuery group.

comment:4 Changed 11 years ago by brandon

Resolution: fixed
Status: reopenedclosed

The leaks at runtime caused by jQuery.support are fixed in SVN (at least according to drip). Feel free to reopen by attaching a test case (against SVN) that shows the leaks you are experiencing.

If you are concerned about the rest of the leaks on the jQuery page, file a bug and set component to "site". jQuery itself can't prevent all memory leaks from developers code.

Note: See TracTickets for help on using tickets.