Bug Tracker

Opened 11 years ago

Closed 9 years ago

#4535 closed bug (duplicate)

using show with parameters removes attributes from td

Reported by: tonyt Owned by:
Priority: major Milestone: 1.4
Component: effects Version: 1.3.2
Keywords: Cc:
Blocked by: Blocking:

Description

Test case

<table> <tbody> <tr> <td id="hcol" colspan = "4" style="display:none"> somedata</td> </tr> <tr> <td>one</td> <td>one</td> <td>one</td> <td>one</td> </tr> </tbody> </table>

Then after $("#hcol").show("normal");

from the table the colspan atribute is removed and the structure of the table is lost.

Attachments (1)

showanimatebug.html.zip (544 bytes) - added by tonyt 11 years ago.
Show animate bug

Download all attachments as: .zip

Change History (6)

comment:1 Changed 11 years ago by dmethvin

Same as #4492 (that time with rowspan) but a better generic description. Can you provide a complete test case?

comment:2 Changed 11 years ago by dmethvin

Component: unfilledfx

Changed 11 years ago by tonyt

Attachment: showanimatebug.html.zip added

Show animate bug

comment:3 Changed 11 years ago by tonyt

Sure. See the attached file Thanks Tony

comment:4 Changed 10 years ago by petersendidit

The problem was that jQuery was using display:block for all animations, but doesn't need to when the element is a table, tbody, tr, td, th

http://github.com/petersendidit/jquery/commit/0017c96739387b24cbb7bd1a9506eb0950dbbe4c

comment:5 Changed 9 years ago by snover

Resolution: duplicate
Status: newclosed

Duplicate of #2185.

Note: See TracTickets for help on using tickets.