Bug Tracker

Opened 11 years ago

Closed 11 years ago

#4502 closed bug (duplicate)

:enabled selector

Reported by: ultimas Owned by: john
Priority: minor Milestone: 1.4
Component: selector Version: 1.3.2
Keywords: selector enabled disabled Cc:
Blocked by: Blocking:

Description

Hi,

I got several inputs with the same name but different types on the same page, some are type='text' and others type='hidden'.

Executing the following selector against them, jQuery returns different results in version 1.2.6 and 1.3.2:

[name='x']:enabled

1.2.6: It returns every non-disabled element, as I would expect

1.3.2: It returns only the ones of type='text'. To workaround it I used: [name='x']:not(:disabled)

Change History (2)

comment:1 Changed 11 years ago by ultimas

Forgot to inform, I saw this behaviour on Firefox, don't know about it on IE

comment:2 Changed 11 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Duplicate of #4013.

Note: See TracTickets for help on using tickets.