Bug Tracker

Opened 11 years ago

Closed 9 years ago

Last modified 8 years ago

#4478 closed bug (duplicate)

jsonp not working in ie6

Reported by: sthumphr Owned by:
Priority: major Milestone: 1.4
Component: ajax Version: 1.3.2
Keywords: jsonp, ie 6.0 Cc:
Blocked by: Blocking:

Description

The jsonp example does not seem to work in IE 6.0.

http://docs.jquery.com/Ajax/jQuery.getJSON

<!DOCTYPE HTML PUBLIC "-W3CDTD HTML 4.01 TransitionalEN"

"http://www.w3.org/TR/html4/loose.dtd">

<html> <head>

<script src="http://code.jquery.com/jquery-latest.js"></script>

<script> $(document).ready(function(){

$.getJSON("http://api.flickr.com/services/feeds/photos_public.gne?tags=cat&tagmode=any&format=json&jsoncallback=?",

function(data){

$.each(data.items, function(i,item){

$("<img/>").attr("src", item.media.m).appendTo("#images"); if ( i == 3 ) return false;

});

});

}); </script> <style>img{ height: 100px; float: left; }</style>

</head> <body>

<div id="images"> </div>

</body> </html>

Change History (3)

comment:1 Changed 10 years ago by dmethvin

Component: unfiledajax

comment:2 Changed 9 years ago by addyosmani

Resolution: duplicate
Status: newclosed

comment:3 Changed 9 years ago by addyosmani

Duplicate of #4378 .

Note: See TracTickets for help on using tickets.