Bug Tracker

Opened 10 years ago

Closed 8 years ago

Last modified 8 years ago

#4468 closed bug (duplicate)

:not() Selector not working properly with :first in IE browsers

Reported by: swalke16 Owned by: john
Priority: low Milestone: 1.next
Component: selector Version: 1.4.4
Keywords: not first Cc:
Blocked by: Blocking:

Description

If I have a selector such as the following:

$('.value-container:not(:first)').remove();

This will remove ALL elements that have the value-container class when using an IE browser. When using Firefox this works correctly and removes all but the first element that has the value-container class.

Attachments (1)

NotBug.htm (689 bytes) - added by swalke16 10 years ago.
Simple HTML page that reproduces the described issue.

Download all attachments as: .zip

Change History (7)

Changed 10 years ago by swalke16

Attachment: NotBug.htm added

Simple HTML page that reproduces the described issue.

comment:1 Changed 10 years ago by mellamokb

Just found the same issue. $('.value-container').not(':first') seems to be a suitable workaround for both IE and FF.

comment:2 Changed 8 years ago by dmethvin

Milestone: 1.3.2
Priority: majorlow
Status: newopen
Version: 1.3.21.4.4

comment:3 in reply to:  1 Changed 8 years ago by anonymous

Replying to mellamokb:

Just found the same issue. $('.value-container').not(':first') seems to be a suitable workaround for both IE and FF.

Thanks - so much - found this doing a google search and it was the perfect answer.

comment:4 Changed 8 years ago by danheberden

Milestone: 1.next

Still present on IE6-8. Works as expected on IE9 and other browsers.

A more visual test-case: http://jsfiddle.net/danheberden/ZBX76/

comment:5 Changed 8 years ago by john

Resolution: duplicate
Status: openclosed

comment:6 Changed 8 years ago by john

Duplicate of #4028.

Note: See TracTickets for help on using tickets.