Bug Tracker

Opened 11 years ago

Closed 10 years ago

#4451 closed bug (duplicate)

Sibling selector in 1.3.2

Reported by: yodza Owned by: john
Priority: major Milestone: 1.3.2
Component: selector Version: 1.3.2
Keywords: sibling Cc:
Blocked by: Blocking:

Description

From 1.3.1 to 1.3.2 sibling selector does not work anymore: http://jquery.nodnod.net/cases/277

<script> $(document).ready(function() {

module("Sibling in jquery-1.3.2"); test("Sibling filter", function() {

var length = jQuery("li.selected").siblings("li").length; equals(length, 2, "sibling filter length");

});

test("Sibling selector", function() {

var length = jQuery("li.selected ~ li").length; equals(length, 2, "sibling selector length");

});

}); </script>

<ul>

<li class="selected">ichi</li> <li>ni</li> <li>san</li>

</ul>

Change History (1)

comment:1 Changed 10 years ago by john

Resolution: duplicate
Status: newclosed

Duplicate of #4243.

Note: See TracTickets for help on using tickets.