Bug Tracker

Opened 11 years ago

Closed 10 years ago

Last modified 8 years ago

#4435 closed enhancement (fixed)

Parse Error cause being lost

Reported by: nunfur Owned by:
Priority: minor Milestone: 1.4.1
Component: ajax Version: 1.4
Keywords: Cc:
Blocked by: Blocking:

Description

I recently started working with jQuery, using its ajax features. I needed to obtain and parse an RSS feed. this ajax call was failing and i could not find out what was happening.

The error was a parse error, if when jQuery tries to parse the HttpData the status is changed to "parseerror", the error function is called but the original error is lost.

Anyway to change this so the cause can reach the error function?

Orinal code[line 3582]:

try {

process the data (runs the xml through httpData regardless of callback)

data = jQuery.httpData( xhr, s.dataType, s );

} catch(e) {

status = "parsererror";

}

Change History (1)

comment:1 Changed 10 years ago by john

Milestone: 1.41.4.1
Priority: trivialminor
Resolution: fixed
Status: newclosed
Version: 1.3.21.4
Note: See TracTickets for help on using tickets.