Bug Tracker

Opened 10 years ago

Closed 10 years ago

#4411 closed bug (invalid)

validation plug-in 1.5.2 - internet explorer and click event

Reported by: jballon Owned by:
Priority: major Milestone: 1.4
Component: plugin Version: 1.3.2
Keywords: validation Cc:
Blocked by: Blocking:

Description

With jQuery 1.3.2 and IE 7 & 8, the delegation of the onclick event causes the submit button to not work, when I change the event to occur onchange the form and validation work normally, additionally I am unable to check the checkboxes. It appears that a return false is being generated causing the event to be canceled.

Not sure why a click event is used instead of change event is being used.

.delegate("click", ":radio, :checkbox", delegate);

.delegate("change", ":radio, :checkbox", delegate);

Change History (2)

comment:1 in reply to:  description Changed 10 years ago by jballon

Replying to jballon:

Disregard found the issue caused by other JavaScript interfering, can not delete or close my own tickets - go figure.

comment:2 Changed 10 years ago by dmethvin

Resolution: invalid
Status: newclosed

Closed per your request.

Note: See TracTickets for help on using tickets.