Bug Tracker

Opened 10 years ago

Closed 10 years ago

#4384 closed bug (duplicate)

jQuery.get doesn't shift all arguments

Reported by: rogpeppe Owned by:
Priority: minor Milestone: 1.4
Component: ajax Version: 1.3.2
Keywords: Cc: rogpeppe@…
Blocked by: Blocking:

Description

by inspection in the source code, if the data argument is omitted, then the type parameter will be overwritten. (also "ommited" is not spelled that way!)

Attachments (1)

get_post_shift_args.patch (1.4 KB) - added by JDay 10 years ago.

Download all attachments as: .zip

Change History (3)

comment:1 Changed 10 years ago by JDay

jQuery.post is also affected. Attached a patch which fixes both functions (but not the typo), with a testcase.

Changed 10 years ago by JDay

Attachment: get_post_shift_args.patch added

comment:2 Changed 10 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Duplicate of #3775.

Note: See TracTickets for help on using tickets.