Skip to main content

Bug Tracker

Side navigation

#437 closed enhancement (fixed)

Opened November 25, 2006 09:23AM UTC

Closed December 23, 2006 05:50PM UTC

Last modified June 19, 2007 06:50AM UTC

Remove ancestor()/ancestors() in favor of parent()/parents()

Reported by: joern Owned by:
Priority: minor Milestone: 1.1a
Component: core Version: 1.1a
Keywords: Cc:
Blocked by: Blocking:

I don't think we need two ways to do exactly the same thing, and so far parent/parents is far more "popular".

Attachments (0)
Change History (9)

Changed November 29, 2006 09:16PM UTC by laurenty@gma comment:1

I agree, it is actually confusing to have both.

I am still not sure if parents() is an alias of ancestors() or not. The

documentation for parents() shows ancestors() in its example.

Changed November 29, 2006 09:22PM UTC by Dave comment:2

I prefer parents so this sounds good to me.

Changed November 29, 2006 10:02PM UTC by glen@kokopop comment:3

I agree. I am not sure why there are multiple ways of calling the exact same thing. Parents is better. Ancestors makes me think of mothballs and wagon trains.

Changed November 29, 2006 10:56PM UTC by blair comment:4

Another vote for just parents.

Changed November 30, 2006 01:01AM UTC by andrea ercol comment:5

this is easy: get rid of it

Changed November 30, 2006 07:54AM UTC by paul.bakaus@ comment:6

parents() only.

Changed November 30, 2006 11:58AM UTC by alan@ralenta comment:7

I agree that the duplication is pointless and confusing.

The word 'parent' sounds to me more like just the next node up the tree, whereas 'ancestor' is anything above (although I see my dictionary says that 'parent' can mean 'ancestor' too). Also 'parent' can return one or more parents as we are working on a node set, so the pluralisation is confusing here.

Starting from scratch, I would go for either 'parent' and 'ancestor' or 'parents' and 'ancestors', but both are non-starters from where we are.

'parent' and 'ancestors' makes some sense, and that is what I've used in the past, but the pluralisation is a bit dubious.

So, by a roundabout route, I agree that 'parent' and 'parents' seems the best resolution.

Changed November 30, 2006 05:08PM UTC by Alex Cook comment:8

parent()/parents() makes more sense to me, drop the other.

Changed December 23, 2006 05:50PM UTC by john comment:9

milestone: → 1.1
resolution: → fixed
status: newclosed

Done, in SVN rev 777.