Bug Tracker

Opened 11 years ago

Closed 10 years ago

#4363 closed bug (invalid)

[autocomplete] repeating focus

Reported by: Kezzer Owned by: joern
Priority: minor Milestone: 1.4
Component: unfiled Version: 1.3.2
Keywords: autocomplete focus Cc:
Blocked by: Blocking:

Description

If, for example, two input boxes are next to each other and the tab key is used to move from the first text box to the second, the focus will come back to the first text box if autocomplete is applied to the first with an item selected.

This can be reproduced by simply entering some search criteria, selecting an item from the autocomplete then hitting the tab key which _should_ take you to the next text box. It will, but will promptly bring the focus back to the first text box.

Fixed for IE7 using the following inserted AFTER case KEY.RETURN on line 136 (the following was inserted on line 145):

case KEY.TAB:

selectCurrent(); break;

It's a quick fix only, but seems to do the trick. You cannot use !options.selectFirst as stated by #3423 because some of us actually disable options.selectFirst causing this fix to not work. The problem with this option is that it will most likely not work with Opera. Needs testing.

Change History (2)

comment:1 Changed 10 years ago by dmethvin

Owner: set to joern

This is not a jQuery core bug. Please use the jQuery forums or contact the author via the method they request. For jQuery UI plugins, please file a bug on http://dev.jqueryui.com .

comment:2 Changed 10 years ago by dmethvin

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.