Bug Tracker

Opened 11 years ago

Closed 11 years ago

#4340 closed bug (duplicate)

Wrong offset counting in FF2 and Safari for fixed elements

Reported by: aichinge Owned by: brandon
Priority: major Milestone: 1.4
Component: offset Version: 1.3.2
Keywords: Cc:
Blocked by: Blocking:

Description

Hi, I play with counting offset for fixed element which has 50px top property and the page is 100px scrolled down. (CSS1Compact mode)

Majority of browser return CSS/offset top for this element 150px, but FF2 and Safari/Chrome return only 50px. I think that the behave of it have to be same.

I suggest that jQuery have to adds offsets from offsetParents and stop at the first fixed offsetParent and adds scrollTop/Left and stops counting for FF2 and Safari/Chrome.

Change History (2)

comment:1 Changed 11 years ago by joelg

I have just submitted my fix for this to a duplicate ticket for this same issue - http://dev.jquery.com/ticket/4263.

comment:2 Changed 11 years ago by brandon

Component: dimensionsoffset
Resolution: duplicate
Status: newclosed

duplicate of #4263

Note: See TracTickets for help on using tickets.