Bug Tracker

Opened 11 years ago

Closed 11 years ago

#4326 closed bug (invalid)

json response

Reported by: veniamin.medvedev Owned by:
Priority: major Milestone: 1.4
Component: ajax Version: 1.3.2
Keywords: Cc: flesler, veniamin.medvedev
Blocked by: Blocking:

Description

Hello in Your function httpData: function( xhr, type, s ) { You have if( typeof data === "string" ){

if ( type == "script" )

jQuery.globalEval( data );

if ( type == "json" )

data = windoweval?("(" + data + ")");

}

In my case I have data as an empty string I think You need to check if data isn't empty

Thanks

Change History (2)

comment:1 Changed 11 years ago by flesler

Cc: flesler veniamin.medvedev added

Are you getting some kind of error ? Please include more details.

comment:2 Changed 11 years ago by brandon

Resolution: invalid
Status: newclosed

If data is an empty string then there is nothing to eval. Not sure what the issue is here. Please feel free to reopen with a simplified test case.

Note: See TracTickets for help on using tickets.