Bug Tracker

Opened 10 years ago

Closed 9 years ago

#4306 closed bug (worksforme)

children selector error in opera

Reported by: gogloid Owned by: gogloid
Priority: major Milestone:
Component: selector Version: 1.3.2
Keywords: children selector opera Cc:
Blocked by: Blocking:

Description

$('ul',element).append('<li>something</li>').children('li:last').length is 0 in Opera (9.64) but $('ul',element).append('<li>something</li>').children('li:last').length is 1 in Firefox (3. 0. 7.)

Change History (5)

comment:1 Changed 9 years ago by miketaylr

Resolution: invalid
Status: newclosed

Please reopen with a working test case.

comment:2 Changed 9 years ago by miketaylr

Milestone: 1.4
Resolution: invalid
Status: closedreopened

comment:3 Changed 9 years ago by miketaylr

Keywords: needsreview added
Owner: changed from john to gogloid
Status: reopenedpending

Can you verify if this still happens using the latest jQuery? If so, can you reopen with a working test case? Thanks.

comment:4 Changed 9 years ago by jitter

I can't reproduce the bug described. I tested with all jQuery 1.3.2, 1.4.2, 1.4.3 and jQuery 0 GIT and Opera 9.64, 10.10, 10.54 and 10.63 but none show the behavior described by the original poster

test case

Last edited 9 years ago by jitter (previous) (diff)

comment:5 Changed 9 years ago by dmethvin

Keywords: needsreview removed
Resolution: worksforme
Status: pendingclosed

Thanks jitter!

Note: See TracTickets for help on using tickets.