Bug Tracker

Opened 11 years ago

Closed 9 years ago

Last modified 8 years ago

#4303 closed bug (invalid)

including jquery in firefox extension XUL overlay causes overlay to stop loading

Reported by: jdollard Owned by:
Priority: major Milestone: 1.4
Component: core Version: 1.3.2
Keywords: Cc:
Blocked by: Blocking:

Description

When I include the jquery library in my firefox extension XUL overlay the overlay doesn't load, along with all extensions after it. I don't get any errors from firefox to help debug this.

I am using the latest stable version of firefox (3.0.7)

This problem didn't happen with jquery version 1.2.6

I have tried this in the latest jquery from subversion and the problem is still occurring

Change History (5)

comment:1 Changed 9 years ago by dmethvin

Resolution: fixed
Status: newclosed

Too vague and no test case, possibly a dup of #3555 or #4352.

comment:2 Changed 9 years ago by dmethvin

Resolution: fixed
Status: closedreopened

comment:3 Changed 9 years ago by dmethvin

Resolution: invalid
Status: reopenedclosed

comment:4 Changed 9 years ago by Becker

Repro: In firefox(3.6.12) install LastPass addon. This adds an icon to the toolbar. Create a new firefox extension In the extension's overlay code added in. Does not matter where in the overlay tag.

<script src="chrome://extension/content/jquery-1.4.2.min.js"/>

Install your extension The last pass icon in the toolbar goes away.

comment:5 in reply to:  4 Changed 9 years ago by anonymous

Replying to Becker:

Repro: In firefox(3.6.12) install LastPass addon. This adds an icon to the toolbar. Create a new firefox extension In the extension's overlay code added in. Does not matter where in the overlay tag.

<script src="chrome://extension/content/jquery-1.4.2.min.js"/>

Install your extension The last pass icon in the toolbar goes away.

This tracks the issue and has a work around in firefox. https://gist.github.com/112562

Note: See TracTickets for help on using tickets.