Bug Tracker

Opened 11 years ago

Closed 10 years ago

#4292 closed bug (invalid)

[autocomplete] unautocomplete does not work properly with jQuery 1.3.2

Reported by: till Owned by:
Priority: minor Milestone: 1.3.2
Component: plugin Version: 1.3.2
Keywords: autocomplete, bassistance, plugin, unbind Cc:
Blocked by: Blocking:

Description

The unautocomplete method does not work correctly in latest autocomplete plugin 1.0.2 with jQuery 1.3.2

unautocomplete() should remove all autocomplete functionality from a jQuery object. The problem is that apparently jQuery's unbind() without parameters does not unbind the plugin's keydown handler. This results in multiple keydown handler calls, if one binds another autocomplete afterwards (of the previous binded autocompletes as well as from the current new one).

Fix would be to do this specifically. In jquery.autocomplete.js line #196 the generic $input.unbind(); is done; before that a $input.unbind("keydown.autocomplete"); is needed.

(This might be a jQuery bug.)

Change History (2)

comment:1 Changed 11 years ago by till

Forgot to mention unautocomplete() works correctly with jQuery 1.2.6 (which is the version the plugin was deployed with)

comment:3 Changed 10 years ago by dmethvin

Resolution: invalid
Status: newclosed

This is not a jQuery core bug. Please report plugin bugs to the plugin's author, or ask on the jQuery forums. jQuery UI bugs should be reported on the UI bug tracker, http://dev.jqueryui.com .

Note: See TracTickets for help on using tickets.