Bug Tracker

Opened 11 years ago

Closed 10 years ago

#4279 closed bug (invalid)

F is undefined

Reported by: derekr Owned by:
Priority: major Milestone: 1.4
Component: unfiled Version: 1.3.2
Keywords: Cc:
Blocked by: Blocking:

Description

I am getting this error in the jquery-1.3.2.min.js file on line 19 (via firebug). I am using the calculator plugin (more specifically the sum function), but since the error is in the jquery file I figured I should post it here.

<pre><code> F is undefined F()()jquery-1....2.min.js (line 19) F()()jquery-1....2.min.js (line 19) init()()jquery-1....2.min.js (line 12) init()()jquery-1....2.min.js (line 12) F()()jquery-1....2.min.js (line 19) cleanseNumber()()jquery.c...on.min.js (line 14) recalc()main.js (line 66) F()()jquery-1....2.min.js (line 19) F()()jquery-1....2.min.js (line 19) [Break on this error] (function(){var R=/((?:\((?:\([()]+\)|[...(J,typeof K==="string"?K:K+"px")}})})(); </code></pre>

Attachments (1)

main.js (2.5 KB) - added by derekr 11 years ago.
My custom js file.

Download all attachments as: .zip

Change History (7)

Changed 11 years ago by derekr

Attachment: main.js added

My custom js file.

comment:1 Changed 11 years ago by dmethvin

Can you reduce this to a simple test case that includes the html? Also, please use the uncompressed version of jQuery if possible.

comment:2 Changed 11 years ago by joshcdsi

In case this helps -- I encountered this same error when using the live() method, and it was a result of my having referenced a function as

functionName()

instead of

functionName

Apparently the open/close parens screwed it up.

Josh

comment:3 Changed 11 years ago by jdyndale

I am getting the same error. I get it when I use an Accordion from the UI library (jQuery UI 1.7). I tried using the non-minified version, and then I got the following error:

Line 1279:

elem is undefined [Break on this error] var id = elem[ expando ];

comment:4 Changed 11 years ago by jdyndale

To clarify: The above error is in the jQuery-1.3.2.js file.

I just tried with the 1.3.1 version (both minified and non-minified). Exactly the same error, but on line 1263 in the non-minified 1.3.1 version.

comment:5 Changed 11 years ago by chrisrbailey

I'm getting this error in Safari and Firefox as well. In Safari it says:

TypeError: Result of expression 'F' [undefined] is not an object

I'm using jQuery-1.3.2.min.js.

comment:6 Changed 10 years ago by dmethvin

Resolution: invalid
Status: newclosed

If you find this ticket via Google, please post on a forum to get help in debugging your application. Bug reports should not be filed using the minimized version of jQuery, and the report should always include a test case that clearly demonstrates the problem.

Note: See TracTickets for help on using tickets.