Bug Tracker

Opened 11 years ago

Closed 11 years ago

Last modified 9 years ago

#4249 closed bug (invalid)

Odd string to number conversion

Reported by: chrisbarr Owned by:
Priority: low Milestone: 1.4
Component: css Version: 1.3.2
Keywords: Cc:
Blocked by: Blocking:

Description

If I have a z-index of 100 on an item and I run the following code:

$("#myThing").css("z-index",$("#myThing").css("z-index")+100);

the new z-index is 100100 not 200 as I would have expected.

Change History (3)

comment:1 Changed 11 years ago by chrisbarr

Several people have told me this is the expected behavor and not a bug. $(x).css() always returns a string. I need to use parseInt() to convert it to an integer.

Please close this ticket - sorry for the trouble.

comment:2 Changed 11 years ago by dmethvin

Resolution: invalid
Status: newclosed

comment:3 Changed 9 years ago by jitter

Component: unfiledcss
Priority: minorlow
Note: See TracTickets for help on using tickets.