Bug Tracker

Opened 10 years ago

Closed 8 years ago

Last modified 8 years ago

#4228 closed bug (worksforme)

class selector regression in xhtml in firefox

Reported by: anko Owned by: john
Priority: major Milestone: 1.4
Component: selector Version: 1.3.2
Keywords: xhtml regression Cc:
Blocked by: Blocking:

Description

The latest version of jquery (1.3.2) has a regression in selecting xhtml nodes by class and changing attributes on them. Attached is a test file. If you include jquery 1.3.1, the svg elements of the class disappear onload. In jquery 1.3.2, they do not.

$(".brushcursor").attr("cx", pos ); $(".brushcursor").attr("cy", pos ); $(".brushcursor").attr("x", pos ); $(".brushcursor").attr("y", pos );

It's either a problem with the selector or the attribute changing code, but I don't know how to narrow it down futher.

Attachments (1)

svgtest.xhtml (1.9 KB) - added by anko 10 years ago.
test case. The dashed squares and circles should be hidden onload.

Download all attachments as: .zip

Change History (8)

Changed 10 years ago by anko

Attachment: svgtest.xhtml added

test case. The dashed squares and circles should be hidden onload.

comment:1 Changed 10 years ago by dmethvin

Component: unfilledselector
Owner: set to john

comment:2 Changed 10 years ago by anko

I should note this happens on firefox 3.0 and firefox 3.1

comment:3 Changed 10 years ago by anko

same in opera 10 alpha

comment:4 Changed 10 years ago by anko

same in safari 4 beta

comment:5 Changed 8 years ago by addyosmani

Resolution: worksforme
Status: newclosed

This appears to be working fine now with jQuery 1.4.4 RC2 http://jsfiddle.net/addyosmani/8SWQu/

comment:6 Changed 8 years ago by anko

That svg doesn't even work when you try it on jsfiddle.

If you remove all javascript from the test case, and jsut view it locally you will see what it looks like when it's broken.

The squares and circles should disappear if you try the test case with jquery 1.3.1

comment:7 Changed 8 years ago by snover

jQuery doesn’t support embedded SVG right now. It may be introduced in 1.5; watch #7584 to stay up-to-date.

Note: See TracTickets for help on using tickets.