Bug Tracker

Opened 11 years ago

Closed 11 years ago

#4149 closed bug (duplicate)

css(property, value) has a problem??

Reported by: Jumann Owned by:
Priority: major Milestone: 1.3.2
Component: core Version: 1.3.1
Keywords: Cc:
Blocked by: Blocking:

Description

javascript:(function(){window.t=document.createElement('script');window.t.src='http://ajax.googleapis.com/ajax/libs/jquery/1.3/jquery.js';window.document.body.appendChild(window.t);setTimeout(function(){jQuery('body').css('padding-top',30);},2000)})();

You can copy the sentence above here. Then link to http://help.cc.tw.yahoo.com/index.html?product=news and paste it to address bar. It raised exception which is name.replace is not a function at line 1043 in jquery 1.3.1

Change History (2)

comment:1 Changed 11 years ago by Rwhitbeck

You're injecting jQuery onto a page it wasn't built for. I think the .replace function is getting overloaded in a way it wasn't meant to by the page author.

I don't think this is a jQuery problem.

comment:2 Changed 11 years ago by john

Component: unfilledcore
Resolution: duplicate
Status: newclosed

That page uses Object.prototype, which is breaking things. Thus I'm marking this as a duplicate of #2721.

Note: See TracTickets for help on using tickets.