Bug Tracker

Opened 11 years ago

Closed 11 years ago

#4133 closed bug (invalid)

height() function not accurate in firefox

Reported by: liio Owned by:
Priority: major Milestone: 1.3.2
Component: unfiled Version: 1.3.1
Keywords: Cc:
Blocked by: Blocking:

Description

I found this in following code: <div id="test"> <ul>

<li></li> <li></li>

<ul> </div>

$("#test").height(); the retreived height value is only accurate when margin and padding are all zero.

this error only occurs in Firefox.

jquery version: 1.3.1 ff version: Mozilla/5.0 (Windows; U; Windows NT 5.2; zh-CN; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3 (.NET CLR 3.5.30729)

Change History (2)

comment:1 Changed 11 years ago by dmethvin

When I look at that HTML in Firefox there are two empty bullets. The height returns 16. What value did you expect? When you say "margin and padding are all zero" which elements do you mean?

comment:2 Changed 11 years ago by dmethvin

Resolution: invalid
Status: newclosed

Please reopen if the problem is still there and explain the expected results.

Note: See TracTickets for help on using tickets.