Bug Tracker

Opened 11 years ago

Closed 10 years ago

#4121 closed bug (invalid)

Interface breaks animate with scrollTop

Reported by: ewilliams Owned by:
Priority: major Milestone: 1.3.2
Component: unfiled Version: 1.3.1
Keywords: Interface animate scrollTop Cc:
Blocked by: Blocking:

Description

Apologies if this is not the right place to file this bug -- I followed the link from the Interface home page.

I'm attempting to use code like the following:

$('#container').animate({scrollTop: 0}, 500);

This works with jQuery but not with Interface. I have tested using Interface 1.2 and jQuery 1.2.6 and 1.3.1 in Firefox 3.0.1 and Safari 3.2.1.

In the attached example there is a div, #container, that contains a bunch of other divs. There is also a button that executes the code above. If you scroll #container down and click the button #container's scrollbar will disappear and reappear but no scrolling will occur. If you remove the interface.js include the code will work.

Thanks, Eric

Attachments (1)

test.html (499 bytes) - added by ewilliams 11 years ago.

Download all attachments as: .zip

Change History (2)

Changed 11 years ago by ewilliams

Attachment: test.html added

comment:1 Changed 10 years ago by dmethvin

Resolution: invalid
Status: newclosed

This is probably due to Interface changing Object.prototype, but it's not a bug in jQuery.

Note: See TracTickets for help on using tickets.