Bug Tracker

Opened 11 years ago

Closed 9 years ago

Last modified 8 years ago

#4108 closed bug (worksforme)

:not(:last) selector fails

Reported by: garito Owned by: john
Priority: major Milestone: 1.3.2
Component: selector Version: 1.3.1
Keywords: Cc:
Blocked by: Blocking:

Description

If you try something like:

$(this).parents(('dl:not(:last))

returns all the dl parents of this instead of all the dl parents except the last one as expected

Ricardo Tomasi said here: http://groups.google.com/group/jquery-en/browse_thread/thread/acc39ea6a0742cbe that this is an expected behavior but I don't think so because it breaks the logical behaviour (you could read my opinion in the group threat)

You could see a test case at: http://jquery.nodnod.net/cases/85 as pointed in the threat

If Ricardo Tomasi's point of view is correct in your opinion I suggest a poll request. I bet you that my opinion wins

Thanks!

Change History (3)

comment:2 Changed 10 years ago by dmethvin

Component: unfilledselector
Owner: set to john

comment:3 Changed 9 years ago by dmethvin

Resolution: worksforme
Status: newclosed

comment:4 Changed 8 years ago by anonymous

I am finding this error too.

Note: See TracTickets for help on using tickets.