Bug Tracker

Opened 14 years ago

Closed 14 years ago

Last modified 13 years ago

#410 closed bug (fixed)

event has no properties

Reported by: dubiousd Owned by:
Priority: major Milestone:
Component: event Version:
Keywords: event Cc:
Blocked by: Blocking:

Description

Line 1024 (uncompressed jquery.js):

event.preventDefault = function() {

Change History (3)

comment:1 Changed 14 years ago by john

Can you provide a test case for this? I can't reproduce it.

comment:2 Changed 14 years ago by joern

This was reported before and happened when triggering an event manually. It's fixed in SVN my creating an empty event object if there is none available:

event = jQuery.event.fix( event || window.event || {} ); // Empty object is for triggered events with no data

Please close as fixed.

comment:3 Changed 14 years ago by john

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.