Bug Tracker

Opened 11 years ago

Closed 10 years ago

#4084 closed enhancement (fixed)

$(document).focus(fn)

Reported by: crucify Owned by:
Priority: major Milestone: 1.4
Component: event Version: 1.3.2
Keywords: document focus Cc:
Blocked by: Blocking:

Description

FF $(document).focus(fn) IE $(document.body).focus(fn)

I wish unify 'document'.

thank you.

Change History (6)

comment:1 Changed 11 years ago by dmethvin

What document type are you using?

comment:2 Changed 11 years ago by crucify

xhtml transitional thank you.

comment:3 Changed 11 years ago by dmethvin

Resolution: duplicate
Status: newclosed

This is a duplicate of #4040, thanks!

comment:4 Changed 11 years ago by john

Resolution: duplicate
Status: closedreopened

comment:5 Changed 11 years ago by john

Component: unfilledevent

This appears to be a separate issue from #4040 - it looks like he wants to unify how the focus event needs to be bound, which is something that we can look in to.

This is similar to the problem where in order to animate the scroll of a page you need to attach to both document.documentElement and document.body.

comment:6 Changed 10 years ago by john

Milestone: 1.3.21.4
Resolution: fixed
Status: reopenedclosed
Version: 1.3.11.3.2

I think this has already been fixed with the introduction of the new focus/blur bubbling code in 1.4.

Note: See TracTickets for help on using tickets.