Bug Tracker

Opened 11 years ago

Closed 11 years ago

#4071 closed bug (invalid)

change() event delegation failing in IE 6

Reported by: dom Owned by: brandon
Priority: major Milestone: 1.3.2
Component: event Version: 1.3.1
Keywords: Cc:
Blocked by: Blocking:

Description

Hi,

It seems like the change() event triggered by a select element is not properly bubbled up to its parents in IE 6 (and I suspect, but haven't been able to check, IE 7 as well).

The attached code works as expected in FF and Opera (triggers an alert on changing the values of one of the select), but not in IE.

Attachments (1)

test-cumulative-ie.html (1.2 KB) - added by dom 11 years ago.
Illustration of change() event not propagated in IE

Download all attachments as: .zip

Change History (3)

Changed 11 years ago by dom

Attachment: test-cumulative-ie.html added

Illustration of change() event not propagated in IE

comment:1 Changed 11 years ago by dmethvin

The change event does not bubble in IE, even though the W3C says it should. The problem is more noticeable now that the .live() function might encourage you to rely on bubbling.

comment:2 Changed 11 years ago by dmethvin

Resolution: invalid
Status: newclosed

There are items on the roadmap to expand .live() support. For now it's working as documented so I'll close this ticket since it's not a bug.

http://docs.jquery.com/Events/live#typefn

Note: See TracTickets for help on using tickets.