Bug Tracker

Opened 10 years ago

Closed 10 years ago

#4063 closed bug (worksforme)

$.getJSON() does not call callback with 0-length content response

Reported by: dr_teeth Owned by:
Priority: major Milestone: 1.3.2
Component: ajax Version: 1.3.1
Keywords: json Cc:
Blocked by: Blocking:

Description

I make a call to a REST service using $.getJSON(), which returns a 0-content-length response. The callback does not get called.

If I make the same call using $.get(), the callback does get called.

If this is intended behavior, please make a note of it in the documentation.

Change History (3)

comment:1 Changed 10 years ago by dr_teeth

In my test case, it did not use JSONP (URL is within same domain).

comment:2 Changed 10 years ago by dmethvin

Can you attach your test case? Here's now $.getJSON is implemented:

getJSON: function( url, data, callback ) {   
   return jQuery.get(url, data, callback, "json");
},

The test case will help clarify things.

comment:3 Changed 10 years ago by dmethvin

Resolution: worksforme
Status: newclosed

Please reopen with a test case if the problem is still there.

Note: See TracTickets for help on using tickets.