Bug Tracker

Opened 11 years ago

Closed 9 years ago

#4043 closed bug (worksforme)

animation on input or textarea results in loss of cursor and possibly keyboard input.

Reported by: smokinggun Owned by:
Priority: major Milestone: 1.3.2
Component: effects Version: 1.3.1
Keywords: input focus animation Cc:
Blocked by: Blocking:

Description

Tested with Wekbit nightly build and FF 3.05

Using code such as the below, animating an input or text area will cause the cursor to disappear for the focused input. On Safari text input is no longer accepted, unless the users clicks back into the input. On FF the

$(".resize").
        focus(function(){$(this).animate({height:"6em"}, 500)}).
        blur(function(){$(this).animate({height:"1em"}, 500)})

There is a demonstration at: http://smokinggun.com/temp/webkit_focus.html

The demonstration includes a non-jQuery animation routine which creates the desired results.

Change History (4)

comment:1 Changed 11 years ago by dmethvin

Great test case! It looks like the problem is in jQuery.fx.step(). When the animation is complete it sets the css overflow and display properties back to their original values. If both of those are commented out, the cursor stays in the textarea.

comment:2 Changed 11 years ago by dmethvin

Component: unfilledfx

comment:3 Changed 9 years ago by dmethvin

Status: newopen

comment:4 Changed 9 years ago by addyosmani

Resolution: worksforme
Status: openclosed

Testing the OP's original reduced test case in FF4, FF3.x and Chrome (latest) I see that this issue is no longer prevalent. Closing as worksforme.

Note: See TracTickets for help on using tickets.