Bug Tracker

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#4039 closed bug (duplicate)

Error updating form attributes in IE

Reported by: malsup Owned by:
Priority: major Milestone: 1.3.2
Component: core Version: 1.3.1
Keywords: Cc:
Blocked by: Blocking:

Description

IE issue:

If a user creates a form with inputs named "action" or "method" jQuery fails when attempting to update the method or action attributes of the form object. This becomes a problem for the Form Plugin which tries to do the following when uploading files:

$form.attr({
    target:   id,
    method:   'POST',
    action:   opts.url
});

In IE, this fails in jQuery 1.3.1 at line 985 (attr fn):

elem[ name ] = value;

Turns out that this also fails in jQuery 1.2.6 but not in jQuery 1.2.3.

A test page is available here:

http://jquery.malsup.com/form/action.html

Change History (2)

comment:1 Changed 11 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Duplicate of #3113

comment:2 Changed 11 years ago by malsup

Oops, sorry for the dup. Footnote: version 2.19 of the From Plugin works around the problem using setAttribute instead of $.fn.attr.

Note: See TracTickets for help on using tickets.