Bug Tracker

Opened 11 years ago

Closed 9 years ago

#4015 closed bug (invalid)

Animation causes repeated div background image requests in IE6

Reported by: dcartoon Owned by:
Priority: major Milestone: 1.3.2
Component: effects Version: 1.3.1
Keywords: background-image, multiple, requests, IE6 Cc:
Blocked by: Blocking:

Description

Scenario: A page has a div with a background-image. An event triggers animation of the div's properties e.g. size or position.

Problem: In IE6, the background-image for the div is requested repeatedly while animation is in progress. Additional images within the div are not affected(i.e. the problem appears to only occur with background images)

Expected: The background-image is requested once when the div is loaded and then no further requests are made.

I have tested this in Firefox 3(Vista), Firefox 2(XP), Safari(Vista) and IE7 (Vista) with no repro.

The repeated requests end up impacting responsiveness since the browser has to potentially make dozens of unnecessary image requests.

This problem also occurs with strict and loose doctypes and affects at least jQuery 1.3.1 and 1.2.6(haven't tested other versions)

I have attached an example page based on one of the jQuery Effects demo pages. The page contains a div which has a background image(the jQuery logo) and an additional image(from the jQuery UI homepage).

I have also attached a snapshot of a session from my debugging proxy which shows the repeated image requests.

Attachments (2)

jquery_test.html (909 bytes) - added by dcartoon 11 years ago.
A simple page that causes the problem to repro in IE6
request_list.jpg (96.6 KB) - added by dcartoon 11 years ago.
Snapshot of requests that occur in IE6 while animating

Download all attachments as: .zip

Change History (5)

Changed 11 years ago by dcartoon

Attachment: jquery_test.html added

A simple page that causes the problem to repro in IE6

Changed 11 years ago by dcartoon

Attachment: request_list.jpg added

Snapshot of requests that occur in IE6 while animating

comment:1 Changed 11 years ago by gabrimonfa

I can confirm that also on jquery-1.3.2

comment:2 Changed 11 years ago by gabrimonfa

This happens when IE6 "Internet Options" > "Temporary Files" is set on "Every time the page is opened".

At each movement IE is trying to reload the page and asks the background image again, resulting in many many requests on each animation.

Setting it on "Automatically" solves the problem. So maybe it turns out to be a IE6 bug, instead of a jquery bug...

comment:9 Changed 9 years ago by dmethvin

Resolution: invalid
Status: newclosed

This appears to be a IE bug caused by incorrect settings.

Note: See TracTickets for help on using tickets.