Bug Tracker

Opened 11 years ago

Closed 11 years ago

#3996 closed bug (wontfix)

Live events and triggerHandler()

Reported by: JuniorZ Owned by:
Priority: major Milestone: 1.3.2
Component: event Version: 1.3.1
Keywords: Cc:
Blocked by: Blocking:

Description

It seems triggerHandler() doesn't trigger live events as expected.

A test case is attached, and more info can be found here (http://groups.google.com/group/jquery-dev/browse_thread/thread/a44a2a9d63a42055?hl=en)

Attachments (1)

test-bug-triggerHandler.html (1.4 KB) - added by JuniorZ 11 years ago.

Download all attachments as: .zip

Change History (3)

Changed 11 years ago by JuniorZ

comment:1 Changed 11 years ago by dmethvin

The docs say: "This particular method triggers all bound event handlers on an element (for a specific event type) WITHOUT executing the browser's default actions nor bubbling."

http://docs.jquery.com/Events/triggerHandler#eventdata

Isn't bubbling needed for .live() to work?

I was never quite sure of the design goals or use cases for .triggerHandler() though. The limit of triggering only for the first element in the jQuery object is unusual as well.

comment:2 Changed 11 years ago by john

Component: unfilledevent
Resolution: wontfix
Status: newclosed

Yeah, Dave makes a good point - I'm going to mark this up as being by design.

Note: See TracTickets for help on using tickets.