Bug Tracker

Opened 11 years ago

Closed 10 years ago

#3984 closed bug (fixed)

XmlHttpRequest.abort() does not fire ajaxStop event

Reported by: klaus Owned by: john
Priority: minor Milestone: 1.4
Component: ajax Version: 1.4a2
Keywords: abort cancel Cc:
Blocked by: Blocking:

Description

The ajaxStop event is not being fired if a request is canceled via XmlHttpRequest abort method.

var xhr = $.ajax(...);
xhr.abort();

Seems to be expected behavior.

Taken from http://ui.jquery.com/bugs/ticket/3903: "Whenever this happens the variable used for the global ajax count jQuery.active should be decremented or ajaxStop will never be fired."

Change History (2)

comment:1 Changed 11 years ago by john

Owner: set to john

comment:2 Changed 10 years ago by john

Milestone: 1.3.21.4
Resolution: fixed
Status: newclosed
Version: 1.3.11.4a2
Note: See TracTickets for help on using tickets.