Bug Tracker

Opened 11 years ago

Closed 11 years ago

Last modified 8 years ago

#3952 closed bug (duplicate)

Cross document error in $.clone for !$.support.noCloneEvent browsers

Reported by: shazam Owned by: flesler
Priority: major Milestone: 1.3.1
Component: core Version: 1.3
Keywords: noCloneEvent clone Cc:
Blocked by: Blocking:

Description

Cloning a node in a child iframe document results in an error on browsers that does not support noCloneEvent because document is used to create temporary div that will contain the cloned node instead of ownerDocument of the cloned node.

Diff attached

Attachments (2)

clone cross document safety hole.diff (543 bytes) - added by shazam 11 years ago.
cloneBug.rar (1.2 KB) - added by shazam 11 years ago.
Demonstrates the clone bug

Download all attachments as: .zip

Change History (5)

Changed 11 years ago by shazam

Changed 11 years ago by shazam

Attachment: cloneBug.rar added

Demonstrates the clone bug

comment:1 Changed 11 years ago by dmethvin

Owner: set to flesler

comment:2 Changed 11 years ago by doug

Compare with ticket #4074. I believe this is fixed in version 1.3.2.

comment:3 Changed 11 years ago by brandon

Resolution: duplicate
Status: newclosed

duplicate of #4074

Note: See TracTickets for help on using tickets.