Bug Tracker

Opened 11 years ago

Closed 11 years ago

Last modified 8 years ago

#3922 closed bug (invalid)

Attribute Selectors Don't Work E[@attr=value]

Reported by: jack_indigo Owned by:
Priority: major Milestone: 1.3.1
Component: core Version: 1.3
Keywords: selector attribute Cc:
Blocked by: Blocking:

Description

There's a 1.3 bug with the selector-by-attribute technique like:

Let's say I have a DIV id=something and inside there's a hyperlink with id=43332, and I want to use the following code to hide it:

$('#something A[@id=43332]').hide();

This used to work with 1.2.6. But not with 1.3. Instead, I get a syntax error that the item cannot be found.

So, I removed the #something out to test, and again, the same error.

I switched back to jQuery 1.2.6 and the problem was resolved.

Note I'm on FF3 on Ubuntu Linux 8.04, whether that has anything to do with this.

Change History (3)

comment:1 Changed 11 years ago by Thasmo

The @ sign in the attribute selector syntax is deprecated in version 1.2.6 and was removed in version 1.3.

Just leave the @ sign ouf of the selector.

comment:2 Changed 11 years ago by jack_indigo

Okay, admin. Didn't realize this. Please close this ticket as "not a bug" then. Thanks.

comment:3 Changed 11 years ago by john

Milestone: 1.31.3.1
Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.