Bug Tracker

Opened 11 years ago

Closed 11 years ago

Last modified 8 years ago

#3915 closed bug (duplicate)

CSS :not selector fails on IE and FF

Reported by: marioestrada Owned by:
Priority: major Milestone: 1.3.1
Component: selector Version: 1.3
Keywords: Cc:
Blocked by: Blocking:

Description

Using the next line causes an infinite loop on FF3 and IE7, works on Chrome:

$('#menu li:not(.actual]) a').length;

also tried:

$('#menu li:not([class=actual]) a').length;
$('#menu li:not([class!=actual]) a').length;

With the following HTML:

   <ul>
      <li class="actual"><a href="">Principal</a></li>
      <li><a href="">One</a></li>
      <li><a href="">Two</a></li>
      <li><a href="">Three</a></li>
      <li><a href="">Four</a></li>
      <li><a href="">Five</a></li>
      <li><a href="">Six</a></li>
      <li><a href="">Seven</a></li>
      <li><a href="">Eight</a></li>
   </ul>

The error reported on firebug shows the infinite loop on line 1774 on the preFilter.TAG function on jQuery.js

Change History (2)

comment:1 Changed 11 years ago by marioestrada

Ok I think this will be fixed on the next version of jQuery: http://dev.jquery.com/ticket/3837

comment:2 Changed 11 years ago by john

Component: unfilledselector
Resolution: duplicate
Status: newclosed

Yeah, this is a duplicate of #3837.

Note: See TracTickets for help on using tickets.