Bug Tracker

Opened 11 years ago

Closed 11 years ago

Last modified 8 years ago

#3909 closed bug (fixed)

The event "select" does not work in IE7

Reported by: Betty Owned by: aflesler
Priority: major Milestone: 1.3
Component: event Version: 1.3
Keywords: select Cc:
Blocked by: Blocking:

Description

Even the example provided in official docs does not work in IE7: http://docs.jquery.com/Events/select

With IE7, if you select some text in the input fields, nothing happens.

Please fix it. Thanks.

Change History (3)

comment:1 Changed 11 years ago by dmethvin

Confirmed with both jQuery 1.3 and 1.2.6 so it's not a regression from there. Also fails in IE8 beta 2.

The problem seems to be that the select event does not bubble in IE. The demo attaches the select event to the document. If you change it to attach directly to the two inputs the demo works correctly.

The best fix may be to document that the event doesn't bubble and change the demo accordingly.

comment:2 Changed 11 years ago by dmethvin

Owner: changed from brandon to aflesler

comment:3 Changed 11 years ago by dmethvin

Resolution: fixed
Status: newclosed

It doesn't look like the select event bubbles in IE8 either, so I updated the documentation to use ":text" as a selector.

Note: See TracTickets for help on using tickets.