Bug Tracker

Opened 13 years ago

Closed 11 years ago

Last modified 10 years ago

#3901 closed enhancement (duplicate)

Automatically disable the Alpha filter in Internet Explorer when opacity is set to 1.0

Reported by: prefect Owned by:
Priority: minor Milestone: 1.3.1
Component: attributes Version: 1.3
Keywords: explorer alpha filter opacity Cc:
Blocked by: Blocking:

Description

As described and discussed in http://groups.google.com/group/jquery-dev/browse_frm/thread/82a7a5d7921e5e1c

The Alpha filter in Internet Explorer causes a few display bugs in certain cases. jQuery automatically enables this for IE when setting the opacity CSS property, and should probably disable it automatically again when the opacity is set to 1.0.

The best way I know is to disable only the Alpha filter, ie. like this: css('filter', "alpha(enabled='false')").

A test case is provided which demonstrates one side effect in IE, and shows a manual work around.

Attachments (1)

jQuery-ie-filters.html (4.6 KB) - added by prefect 13 years ago.
Test case

Download all attachments as: .zip

Change History (5)

Changed 13 years ago by prefect

Attachment: jQuery-ie-filters.html added

Test case

comment:1 Changed 13 years ago by dmethvin

See also #3502.

comment:2 Changed 11 years ago by dmethvin

Component: unfiledattributes

comment:3 Changed 11 years ago by snover

Resolution: duplicate
Status: newclosed

comment:4 Changed 11 years ago by snover

Duplicate of #6652.

Note: See TracTickets for help on using tickets.