Bug Tracker

Opened 11 years ago

Closed 11 years ago

Last modified 8 years ago

#3900 closed bug (duplicate)

jQuery 1.3 using content type application/xhtml+xml in Firefox doesn't work

Reported by: dark_ixion Owned by:
Priority: major Milestone: 1.3
Component: unfiled Version: 1.3
Keywords: xhtml, xhtml+xml, mime, firefox, content-type Cc:
Blocked by: Blocking:

Description

If I'm using jQuery 1.3 with a page with a content type of application/xhtml+xml in Firefox, jQuery's functions do not work.

Test cases:

WORKING - jQuery 1.3 with a content type of application/xhtml+xml:

http://killingcupid.avengedsevenfold.co.uk/jquery_1.php

NOT WORKING - jQuery 1.3 with a content type of text/html:

http://killingcupid.avengedsevenfold.co.uk/jquery_2.php

WORKING - jQuery 1.2.6 with a content type of application/xhtml+xml:

http://killingcupid.avengedsevenfold.co.uk/jquery_3.php

This works okay in Safari and Opera. I don't need to test this in Internet Explorer as it doesn't support that MIME type anyway (so I serve them the incorrect text/html one).

I don't get this problem in Firefox with jQuery 1.2.6.

Change History (2)

comment:1 Changed 11 years ago by dark_ixion

Sorry, that should have read:

Test cases:

NOT WORKING - jQuery 1.3 with a content type of application/xhtml+xml:

http://killingcupid.avengedsevenfold.co.uk/jquery_1.php

WORKING - jQuery 1.3 with a content type of text/html:

http://killingcupid.avengedsevenfold.co.uk/jquery_2.php

WORKING - jQuery 1.2.6 with a content type of application/xhtml+xml:

http://killingcupid.avengedsevenfold.co.uk/jquery_3.php

And I should have mentioned this is in Firefox 3.0.5.

comment:2 Changed 11 years ago by dmethvin

Resolution: duplicate
Status: newclosed

This is a duplicate of #3896, I've linked it from there since this ticket provides several useful test cases. Thanks!

Note: See TracTickets for help on using tickets.