Bug Tracker

Opened 11 years ago

Closed 11 years ago

#3888 closed bug (duplicate)

:not selector doesn't work anymore

Reported by: arsenikstiger Owned by: john
Priority: major Milestone: 1.3.1
Component: selector Version: 1.3
Keywords: :not Cc:
Blocked by: Blocking:

Description

When i wanna use the ':not' selector (eg sample below), it doesn't work. I must use the '.not()' function to have the same results.

Sample (1.2.6 -> Working / 1.3 -> Doesn't work anymore):

alert( $('ul').find('li:not(li:first)').length );

Sample (1.2.6 , 1.3 -> Working):

alert( $('ul').find('li').not('li:first').length );

Change History (1)

comment:1 Changed 11 years ago by john

Milestone: 1.31.3.1
Resolution: duplicate
Status: newclosed

Duplicate of #3814.

Note: See TracTickets for help on using tickets.