Bug Tracker

Opened 11 years ago

Closed 11 years ago

#3887 closed bug (duplicate)

next selector can match the wrong things

Reported by: dalangalma Owned by: john
Priority: major Milestone: 1.3.1
Component: selector Version: 1.3
Keywords: Cc:
Blocked by: Blocking:

Description

I've found a case where the next selector doesn't seem to work. I've got a selector like "span.foo + a" but it'll match all "a" that are after a "span" (of any class, or no class) that appears after an "a".

So "<span/> <a/>" doesn't match, but the second "a" in "<a/> <span/> <a/>" does. I would expect it to only match "a"s that directly follow a "span" with the class "foo".

Here's the demo:

http://brh.numbera.com/experiments/browserdemos/jquery-1.3-adjacent.html

I've also attached the same demo file to this ticket.

Attachments (1)

jquery-1.3-adjacent.html (1.2 KB) - added by dalangalma 11 years ago.
Repro for next selector bug

Download all attachments as: .zip

Change History (2)

Changed 11 years ago by dalangalma

Attachment: jquery-1.3-adjacent.html added

Repro for next selector bug

comment:1 Changed 11 years ago by john

Resolution: duplicate
Status: newclosed

Sounds like this is a duplicate of #3848 (there was a bug with the class filter).

Note: See TracTickets for help on using tickets.