Bug Tracker

Opened 11 years ago

Closed 11 years ago

Last modified 8 years ago

#3865 closed bug (duplicate)

After jQuery update to v1.3 - Infinite loop cause Firefox hangs and IE error.

Reported by: soswow Owned by: john
Priority: critical Milestone: 1.3.1
Component: selector Version: 1.3
Keywords: Cc:
Blocked by: Blocking:

Description

After updating to jQuery to version 1.3 my old script start killing Firefox and cause IE error.

Try to run this code with jQuery 1.3:

$(function(){
    $("#main LI:not(.current) A").css("background-color","gray");
  });

With HTML:

<div id="main">

<ul>

<li class="current"><a href="#">Current</a></li> <li class="item"><a href="#">Item</a></li> <li class="item"><a href="#">Item</a></li>

</ul>

</div>

And you get Firefox fail. IE with text: "Stop running this script?

A script on this page is causing Internet Explorer to run slowly. If it continues to run, your computer may bacome unresponsive"

Chrome works fine.

Attachments (1)

test2.html (721 bytes) - added by soswow 11 years ago.
Reproduction test file

Download all attachments as: .zip

Change History (4)

Changed 11 years ago by soswow

Attachment: test2.html added

Reproduction test file

comment:1 Changed 11 years ago by john

Milestone: 1.31.3.1
Version: 1.3

comment:2 Changed 11 years ago by john

Resolution: duplicate
Status: newclosed

Ok, it looks like this is a duplicate of #3837.

comment:3 Changed 11 years ago by soswow

john, Yes. Sorry, I realy tried to use search before creating new ticket. Next time I will be more considerate.

Note: See TracTickets for help on using tickets.