Bug Tracker

Opened 11 years ago

Closed 11 years ago

#3856 closed bug (invalid)

getJSON doesn't work or eval the response correctly for "application/json" content type

Reported by: CVertex Owned by: flesler
Priority: critical Milestone: 1.3.1
Component: ajax Version: 1.3
Keywords: json application ajax Cc: CVertex, scrollup
Blocked by: Blocking:

Description

this was working fine in 1.2.6. Not sure if it's a change in jquery behaviour or tis a bug.

IN v1.3, getJSON doesn't work or eval the response for "application/json" content type, or any content type for that matter I've tried so far. I'll try a few more.

The upgrade was going so well too :( live event binding rocks!!

Change History (7)

comment:1 Changed 11 years ago by john

Milestone: 1.31.3.1
Owner: set to john
Version: 1.3

comment:2 Changed 11 years ago by john

Owner: changed from john to flesler

Ariel, can you check in to this? I think this behavior may have changed.

comment:3 Changed 11 years ago by scrollup

i got the same problem here. When i try to reduce the problem, adding only jquery-1.3.js and leaving ui and other stuff, getJSON does the callback function. As soon as i add all other plugins getJSON never calls. With the 1.2.6 it works in any combination. So i guess it is some of the plugins.

comment:4 Changed 11 years ago by flesler

Cc: CVertex scrollup added
need: ReviewTest Case
Status: newassigned

CVertex and/or scrollup

Can you provide a test case ? a small html which reproduces the problem. Don't use external includes, just this link for jquery.

comment:5 Changed 11 years ago by scrollup

any small testsuite work smoothly no difference - i can't reproduce the bug in a small environement. It must be a mistake in my code. i compared jquery1.2.3 against jquery1.3

comment:6 Changed 11 years ago by CVertex

I spent a bit of time today looking at this again. The problem I was witnessing was my erroneous code.

getJSON works fine in a normal context for me w/ 1.3.

My problem was switching to the new live event binding which requires event handlers return false. The switch from a event listening plugin to the new live function required I changed which combination of my nested functions needed to return false. The high level of closure nesting was originally difficult for me to trace I think.

comment:7 Changed 11 years ago by dmethvin

Resolution: invalid
Status: assignedclosed
Note: See TracTickets for help on using tickets.