Bug Tracker

Opened 11 years ago

Closed 11 years ago

Last modified 8 years ago

#3821 closed bug (invalid)

[validate] "jQuery.validator.messages is null or not an object." error in ie6 with page encoding set to utf-8

Reported by: park Owned by: joern
Priority: major Milestone: 1.3
Component: plugin Version: 1.2.6
Keywords: validate, ie6, utf-8 Cc:
Blocked by: Blocking:

Description

AFFLICTED BROWSER: ie6 only (works fine in ie7 and FF)

PAGE ENCODING: UTF-8 (works fine with page encoding set to ISO-xxxx-xx)

SYMTOM: Browser throws out a js error and refused to return false and validate upon form submits: "jQuery.validator.messages is null or not an object."

ROOT CAUSE: The regex at line 976 (jquery.validate.js version 1.5) is flawed with utf-8 encoding in ie6.

Change History (2)

comment:1 Changed 11 years ago by dmethvin

Owner: set to joern

comment:2 Changed 11 years ago by joern

Resolution: invalid
Status: newclosed

Can't reproduce. UTF-8 encoding works fine for me; please reopen with a testpage.

Note: See TracTickets for help on using tickets.