Bug Tracker

Opened 11 years ago

Closed 11 years ago

#3819 closed bug (worksforme)

jQuery 1.3b2 selector engine *much* slower than 1.3b1 (FF 3.0.5)

Reported by: doctyper Owned by: john
Priority: major Milestone: 1.3
Component: selector Version: 1.2.6
Keywords: Cc:
Blocked by: Blocking:

Description

This bug is only found under Firefox 3.0.5. FF 3.1 / Safari 3 work fine.

There is an extremely noticeable difference in jQuery's selector engine running FF 3.0.5. Calling jQuery takes up to 12x (!) the time between the two versions. I've set up a test case for you to view. The test uses Firebug to log the time:

Using 1.3b1: http://doctyper.com/stuff/jquery/1.3b1.html

Using 1.3b2: http://doctyper.com/stuff/jquery/1.3b2.html

Attachments (2)

Picture 2.png (147.8 KB) - added by doctyper 11 years ago.
FF 3.0.5 Running 1.3b2
Picture 1.png (147.1 KB) - added by doctyper 11 years ago.
FF 3.0.5 Running 1.3b1

Download all attachments as: .zip

Change History (3)

Changed 11 years ago by doctyper

Attachment: Picture 2.png added

FF 3.0.5 Running 1.3b2

Changed 11 years ago by doctyper

Attachment: Picture 1.png added

FF 3.0.5 Running 1.3b1

comment:1 Changed 11 years ago by john

Resolution: worksforme
Status: newclosed

I really can't confirm this - I keep trying but can't reproduce the massive 10x spike shown here.

Just FYI - this test ends up testing a lot more than just selectors - it also tests the performance of .hide() and .show().

Note: See TracTickets for help on using tickets.