Bug Tracker

Opened 11 years ago

Closed 11 years ago

#3747 closed bug (duplicate)

1.3b1: IMG does not animate properly if CSS width/height set

Reported by: jtnix Owned by:
Priority: critical Milestone: 1.3
Component: effects Version:
Keywords: animate Cc:
Blocked by: Blocking:

Description

Summary: if CSS height/width is set, IMG tags do not animate properly.

1.2.6 test: http://nixbox.com/demos/animate.1.2.6.php

1.3b1 test: http://nixbox.com/demos/animate.1.3b1.php

Detail: Whether IMG tag height/width is set manually via IMG 'style' attribute or stylesheet, jQuery width()/height() or jQuery CSS, .animate function only animates IMG height/width attributes and leaves CSS height/width in original state, effectively hiding animation.

Unsure if this also affects other elements with height/width attributes like IFRAME, etc.

possibly related to: http://dev.jquery.com/ticket/3739

Change History (2)

comment:1 Changed 11 years ago by jtnix

comment:2 Changed 11 years ago by john

Resolution: duplicate
Status: newclosed

Duplicate of #3739.

Note: See TracTickets for help on using tickets.