Bug Tracker

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#3745 closed bug (fixed)

1.3 beta 1: :not(:first) fails

Reported by: pixeline Owned by: john
Priority: major Milestone: 1.3
Component: selector Version: 1.2.6
Keywords: wildcard, selector Cc: pixeline
Blocked by: Blocking:

Description

var allItems = $('div.ds-item', datascape); (...)

$('*', allItems).not('p, a,form').show();

triggers this error in firebug: Error: match[3] is undefined jquery-1.3b1.js Line 1812

testcase here: http://pixeline.be/experiments/jquerybeta/test1.html

it seems related to the use of the wildcard '*' but you're the experts :)

Change History (5)

comment:1 Changed 11 years ago by kswedberg

I think it's related to the .not() method (also :not() selector).

Another test case here: http://13beta.learningjquery.com/13b1.html

This triggers the same error (in Error Console, but not in Firebug): $('li:not(:last-child)')

These return all LI elements, rather than the correct set: $('li').not(':odd') $('li').not(':odd:first')

comment:2 Changed 11 years ago by flesler

Cc: pixeline added
Owner: set to john
Version: 1.2.6

comment:3 Changed 11 years ago by john

Summary: 1.3 beta 1: selector issue1.3 beta 1: :not(:first) fails

This is a duplicate of #3757.

However, the bug that Karl posted is a different one, so I'm just going to morph this ticket to refer to Karl's test case!

comment:4 Changed 11 years ago by john

Resolution: fixed
Status: newclosed

Just landed a fix for this in Sizzle, will be merging into jQuery shortly.

Note: See TracTickets for help on using tickets.