Bug Tracker

Opened 11 years ago

Closed 11 years ago

Last modified 8 years ago

#3724 closed bug (duplicate)

Clone on SSL with Anchor Tag

Reported by: cblaze22 Owned by:
Priority: major Milestone: 1.3
Component: ajax Version: 1.2.6
Keywords: Cc:
Blocked by: Blocking:

Description

I recently ran into a problem with the clone function and SSL with a anchor tag. The problem was IE kept showing that unsecure items were on a page that contained htts:// in the protocol. Searching the html there was nothing. I narrowed the problem down to cloning a anchor . I read that some javascript may cause this issue with SSL enabled sites. My fix was to create the anchor tag by scratch and use that instead.

Change History (5)

comment:1 Changed 11 years ago by cblaze22

comment:2 Changed 11 years ago by dmethvin

need: ReviewTest Case

Can you provide a simple test case? This may be a variation of #1734 but it's hard to tell without a test case.

comment:3 Changed 11 years ago by flesler

Component: unfilledajax
Owner: flesler deleted

comment:4 Changed 11 years ago by cblaze22

Go to in IE7

https://nlets.staging.terralever.com/supportingServices.aspx

It occurs when it hits this line below in common/script/utility.js

var pageObj = page.clone();

and I fixed it with these lines.

var pageObj = $(document.createElement('a')); pageObj.attr('href', $(page).attr('href')).addClass('on').html($(page).html());

comment:5 Changed 11 years ago by dmethvin

Resolution: duplicate
Status: newclosed

This looks like a duplicate of #1734; the IE case for clone goes through jQuery.clean.

Note: See TracTickets for help on using tickets.